Jump to content

Welcome to Netduma Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

XR500 blocking Google services


  • Please log in to reply
5 replies to this topic

#1
redwing497

redwing497

    Advanced Member

  • Members
  • PipPipPip
  • 36 posts
  • Local time: 03:56 AM
Hi all. I'm having a strange problem on my Android phone (pixel 2 XL). When I try to access any Google apps, in particular my Google now news feed and the Play store, it says I have no internet connection even though everything else works. If I toggle WiFi off and use cell data, it loads right up. It's almost like the XR is blocking Google services.

Switch WiFi back on, same problem. I've restarted the phone and router. Nothing fixes it. This didn't happen for the first few months. I updated firmware about 2 weeks ago or so. Any idea? Thanks

#2
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 19,178 posts
  • Local time: 08:56 AM

I believe I've seen this before but its the ISP are you with I think it's Comcast by any chance? Change DNS in Internet Setup and ensure hub is in modem mode does that resolve the issue?


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST



Official DumaOS/XR500 Support Times: 12pm - Midnight BST



Time Converter

If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#3
Killhippie

Killhippie

    Member

  • Members
  • PipPipPip
  • 166 posts
  • Local time: 08:56 AM
  • LocationUK

Hi all. I'm having a strange problem on my Android phone (pixel 2 XL). When I try to access any Google apps, in particular my Google now news feed and the Play store, it says I have no internet connection even though everything else works. If I toggle WiFi off and use cell data, it loads right up. It's almost like the XR is blocking Google services.

Switch WiFi back on, same problem. I've restarted the phone and router. Nothing fixes it. This didn't happen for the first few months. I updated firmware about 2 weeks ago or so. Any idea? Thanks

The XR500 cant block google services really unless someone put them in the block list I guess., I have an android TV and all is working fine. Try using Googles DNS servers and see if that helps as it could be your IP's DNS servers playing up, They are 8.8.8.8 and 8.8.4.4 also reboot your router because if you are using a dynamic IP that will give you a new IP address too, if you have a fixed IP well it cant hurt rebooting anyway. 

 If this didn't try clearing the the cache and data in your Google Play Store and News Feed apps (always a good thing to try) if this didn't work then you may need to go into your Google Play Services and clear the data and cache there. You need to go into your Settings and hit Application manager or Apps. From there, find the Google Play Services app (the puzzle piece). Also searching Android Authority can give you some good ideas too. Hope some of this helps.

https://www.androida...g-fixes-647176/
 



#4
BIG__DOG

BIG__DOG

    Forum Legend

  • Moderators
  • 1,676 posts
  • Local time: 08:56 AM
  • LocationNear Manchester

Change dns in internet setup on the XR500 as Fraser has said, try using 1.1.1.1 and 1.0.0.1 as these dns servers are faster than googles. 


Posted Image Posted Image

#5
Killhippie

Killhippie

    Member

  • Members
  • PipPipPip
  • 166 posts
  • Local time: 08:56 AM
  • LocationUK

Change dns in internet setup on the XR500 as Fraser has said, try using 1.1.1.1 and 1.0.0.1 as these dns servers are faster than googles. 

Not always, it depends where you are. Coudflare like any third party DNS can cause issues with downloading because it confuses CDN's. Browsing may be faster for sure, but I tend to find my own ISP's (IDNet) are the fastest, also being a very small ISP in the Niche grouping I trust them rather than third party DNS providers even though Cloudflare is good from what I hear, but it  could always have issues with the likes of Akamai I believe. It will serve you the nearest server to you which might not always be the closest depending where you like in the world. So take OpenDNS for instance if you lived in Perth your nearest server is on the other side of Australia in Sydney, or if the one server in the UK (Linx) is down you will be using Amsterdam probably.



#6
vShikko

vShikko

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts
  • Local time: 08:56 AM
  • LocationUSA, JPN
I run this utility weekly. It measures DNS Cache/Uncached & DotCom performance then gives you an extensive list of nameservers that are fastest/closest to your ISP. They just recently added Cloudflare & Quad9 in their last nameserver update.

https://www.grc.com/dns/benchmark.htm

Thank me later 🤗




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users