Jump to content
Sign in to follow this  

Ps4pro Geo filter not populating

Recommended Posts

I have used the R1 for years and finally picked up the XR500



I have setup my ps4pro under device manager to playstation

Added ps4 to geo filter as a console - Filtering mode (also tried spectating mode)

profile was set to destiny

I can't see any servers or triangles or anything on the geo filter map




I setup my pc and it works - I can see servers and triangles on the geo filter

PC is set to console (saw this in another thread)

geo filter is set to spectating



Just setup my Xbox1X and everything populates

xbox in device manager

set as console under geo filter in filtering mode

Can see servers and triangles

Share this post

Link to post
Share on other sites

Hi, welcome to the forum!


It's possible your PS4 has been incorrectly identified by the XR500. If you go into the PS4 network settings and check the IP address, does it match the IP address shown on the XR500? By comparing the device in this way you can find out whether you have added the correct device to the Geo-Filter.


Also try deleting the device from the Geo-Filter and adding again. If you find that you have added the wrong device, make sure to find out which device is your PS4 by comparing the address and name it.

Share this post

Link to post
Share on other sites

Yes, I always double check the addresses to make sure they match up.


I have removed the device multiple times from device manager and even set static address to it with no change.

Changed the name in the device manager to make sure I'm adding the correct device too.

Share this post

Link to post
Share on other sites

Did you change the device in Geo-Filter when you switched to WiFi? If not then you had the WiFi PS4 added the whole time not the wired PS4 added. If you did then this doesn't make any sense and would recommend switching ethernet cables.


Yes I deleted the wired geo filter device and setup the wifi device.  My consoles have never been on wifi.  First time was to test out this.


I've tried 3 different ethernet cables

tried removing the wired switch and connect directly to the router

Share this post

Link to post
Share on other sites

ok I just went through and removed all network connections and soft reset my ps4

rebooted the xr500

deleted all the geo filters 

logged out



setup everything again with just the ps4 on wired

and its working now.

I wonder if the xr500 was keeping old settings because I gave my ps4 a different static address



also with my ps4 off and disconnected from ethernet, I couldnt remove the device from device manager



I'll keep testing and re-add my pc and xbox to see what it does


Yea all NAT is open  

PS4 is type 2

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this