Jump to content
Achilles

Random disconnects with wired connection

Recommended Posts

xbox probably has a fix as well, could you please provide a link to the xbox patch?

 

https://news.xbox.com/en-us/insider/

 

I found these notes in one of the updates;

Wi-Fi

  • We have fixed issues with users loosing Wi-Fi coming out of Instant-On.

 

Read more at https://news.xbox.com/en-us/2018/05/08/new-preview-beta-1805-system-update-5-8-18/#ZgLI5wZfdvf6u6Dw.99

 

it might apply to hardwire too

 

 found this on an older update too

 

 

Networking

  • Work has been done to improve the Wi-Fi connectivity when resuming the console from the Instant on mode and a network was not detected until a reboot.

Read more at https://news.xbox.com/en-us/2018/05/03/new-preview-alpha-1805-system-update-5-3-18/#J5XfG18CH5BACHCL.99

Share this post


Link to post
Share on other sites

Spoke with the Xbox Engineer and he said he would reach out to some of the Netgear engineering contacts he has. 

 

He seemed to be following the same train of thought that we had been having, namely, that the switching from 1000Mbps to 10Mbps could be causing an issue with the switch on the XR500. 

 

I gave him the link to this discussion so hopefully he can get a better understanding of what we've tried, experienced etc.

Share this post


Link to post
Share on other sites

currently running debugging firmware with instant start on and ran into the issue today; turning instant on off or to (power saving mode) to see if it happens again

 

we have 2-3 mitigations and instant-on is one of them, but if it is possible could you please try instant-on once more and see if you can repro it? I am trying for almost 4 days, but firmware does not cooperate with me at all, coincidentally it is very stable.

 

if you need help I can walk you through network capture or memory dump capture, just send me a message.

Share this post


Link to post
Share on other sites

Spoke with the Xbox Engineer and he said he would reach out to some of the Netgear engineering contacts he has. 

 

He seemed to be following the same train of thought that we had been having, namely, that the switching from 1000Mbps to 10Mbps could be causing an issue with the switch on the XR500. 

 

I gave him the link to this discussion so hopefully he can get a better understanding of what we've tried, experienced etc.

 

that is good news :)

Share this post


Link to post
Share on other sites

Do you have instant-on enabled? if so you can try to see Ethernet port state. settings->monitoring->statistics; instant-on: While xbox hibernates you will see Ethernet port xbox connected to - to be reset, duplex will change as well re-cycle happens every 1-2min. if that is the case I would recommend to disable instant-on.

 

...unless you have debugging firmware :)

My xbox was not even on at the time and my xbox is not set to instant on. I just lost all connectivity until I reboot the router!

Share this post


Link to post
Share on other sites

probably not related to Ethernet disconnect though, pattern is different. You might found different bug. Area is wide though, could be anything....

 

you can do trace by IP and by dns name. or maybe manual ping plotter where you ping neixt hope, and see what broke in this situation you will not pass second hope.

memory dump would be useful as well.

 

i noticed with factory firmware i had slow memory leak, but i could not verify it since my longest run before reboot was 7 days

 

example of trace command by DNS, you can do it by ip as well.

 

C:\windows\system32>tracert google.com

Tracing route to google.com [216.58.193.78]
over a maximum of 30 hops:

  1     1 ms     1 ms    <1 ms  READYSHARE [192.168.1.1]
  2    11 ms     9 ms    13 ms  96.120.101.177
  3    10 ms    14 ms    10 ms  po-114-rur202.bellevue.wa.seattle.comcast.net [68.87.206.109]
  4    12 ms    11 ms    12 ms  be-203-ar01.seattle.wa.seattle.comcast.net [69.139.164.169]
  5    14 ms    13 ms    11 ms  be-33650-cr01.seattle.wa.ibone.comcast.net [68.86.93.165]
  6    13 ms    13 ms    14 ms  be-10846-pe01.seattle.wa.ibone.comcast.net [68.86.86.90]
  7    12 ms    11 ms    12 ms  as46489-2-c.600wseventh.ca.ibone.comcast.net [50.242.148.22]
  8     *        *        *     Request timed out.
  9    11 ms    11 ms    11 ms  108.170.233.158
 10    12 ms    11 ms    13 ms  209.85.242.39
 11    12 ms    11 ms    12 ms  sea15s07-in-f78.1e100.net [216.58.193.78]

Trace complete.

Share this post


Link to post
Share on other sites

Did you manage to capture the information as per the instructions given?

Just quoted you to bring mine to your attention.

 

My XR500 has totally disconnected and required a reboot again this morning. I have pasted my log in this messgae but it seems to have been reset after a reboot. Getting a tad annoying having to reboot when in the middle of doing something online (this is not xbox related either, I was just watching a movie online). I also had total router lockout and had to reboot from button at back of router!

 

[initialized, firmware version: V2.2.1.10] Sunday, May 13, 2018 08:36:16
[DoS Attack: Ping Sweep] from source: 80.249.99.164, Sunday, May 13, 2018 08:36:20
[DoS Attack: Ping Sweep] from source: 80.249.99.164, Sunday, May 13, 2018 08:36:21
[internet connected] IP address: 78.149.187.169, Sunday, May 13, 2018 08:36:22
[DoS Attack: Ping Sweep] from source: 80.249.99.164, Sunday, May 13, 2018 08:36:22
[Time synchronized with NTP server] Sunday, May 13, 2018 08:36:28
[DumaOS] Starting process manager, Sunday, May 13, 2018 08:36:36
[DumaOS] Non-existent publish method 'licence_permitted', Sunday, May 13, 2018 08:36:36
[DumaOS] App 'com.netdumasoftware.procmanager' initialised & starting., Sunday, May 13, 2018 08:36:36
[DumaOS] Ubus object 'com.netdumasoftware.procmanager' added, attempting to bind pending, Sunday, May 13, 2018 08:36:36
[DumaOS] subscribe to 'com.netdumasoftware.arpwatch' from 'com.netdumasoftware.neighwatch', Sunday, May 13, 2018 08:36:36
[DumaOS] Ubus object 'com.netdumasoftware.systeminfo' added, attempting to bind pending, Sunday, May 13, 2018 08:36:36
[DumaOS] App 'com.netdumasoftware.systeminfo' initialised & starting., Sunday, May 13, 2018 08:36:36
[DumaOS] Ubus object 'com.netdumasoftware.systeminfo' added, attempting to bind pending, Sunday, May 13, 2018 08:36:36
[DumaOS] DHCP new event., Sunday, May 13, 2018 08:36:36
[DumaOS] DHCP new lease allocated., Sunday, May 13, 2018 08:36:36
[DumaOS] DHCP new event., Sunday, May 13, 2018 08:36:36
[DumaOS] DHCP new lease allocated., Sunday, May 13, 2018 08:36:36
[DumaOS] Ubus object 'com.netdumasoftware.neighwatch' added, attempting to bind pending, Sunday, May 13, 2018 08:36:36
[DumaOS] Ubus object 'com.netdumasoftware.neighwatch' added, attempting to bind pending, Sunday, May 13, 2018 08:36:36
[DumaOS] App 'com.netdumasoftware.neighwatch' initialised & starting., Sunday, May 13, 2018 08:36:36
[DumaOS] Ubus object 'com.netdumasoftware.systeminfo' added, attempting to bind pending, Sunday, May 13, 2018 08:36:36
[DumaOS] Ubus object 'com.netdumasoftware.neighwatch' added, attempting to bind pending, Sunday, May 13, 2018 08:36:36
[DumaOS] Ubus object 'com.netdumasoftware.networkmonitor' added, attempting to bind pending, Sunday, May 13, 2018 08:36:36
[DumaOS] Ubus object 'com.netdumasoftware.networkmonitor' added, attempting to bind pending, Sunday, May 13, 2018 08:36:36
[DumaOS] Ubus object 'com.netdumasoftware.networkmonitor' added, attempting to bind pending, Sunday, May 13, 2018 08:36:36
[DumaOS] App 'com.netdumasoftware.networkmonitor' initialised & starting., Sunday, May 13, 2018 08:36:36
[DumaOS] Ubus object 'com.netdumasoftware.networkmonitor' added, attempting to bind pending, Sunday, May 13, 2018 08:36:36
[DumaOS] Waiting for 'com.netdumasoftware.autoadmin' to run before starting, Sunday, May 13, 2018 08:36:37
[DumaOS] App 'com.netdumasoftware.nghal' initialised & starting., Sunday, May 13, 2018 08:36:37
[DumaOS] pending subscription for package 'com.netdumasoftware.devicemanager', Sunday, May 13, 2018 08:36:37
[DumaOS] Waiting for 'com.netdumasoftware.devicemanager' to run before starting, Sunday, May 13, 2018 08:36:37
[DumaOS] Waiting for 'com.netdumasoftware.autoadmin' to run before starting, Sunday, May 13, 2018 08:36:37
[DumaOS] App 'com.netdumasoftware.qos' initialised & starting., Sunday, May 13, 2018 08:36:37
[DumaOS] Ubus object 'com.netdumasoftware.desktop' added, attempting to bind pending, Sunday, May 13, 2018 08:36:38
[DumaOS] Ubus object 'com.netdumasoftware.desktop' added, attempting to bind pending, Sunday, May 13, 2018 08:36:38
[DumaOS] Ubus object 'com.netdumasoftware.desktop' added, attempting to bind pending, Sunday, May 13, 2018 08:36:38
[DumaOS] Ubus object 'com.netdumasoftware.desktop' added, attempting to bind pending, Sunday, May 13, 2018 08:36:38
[DumaOS] Ubus object 'com.netdumasoftware.desktop' added, attempting to bind pending, Sunday, May 13, 2018 08:36:38
[DumaOS] Ubus object 'com.netdumasoftware.desktop' added, attempting to bind pending, Sunday, May 13, 2018 08:36:38
[DumaOS] App 'com.netdumasoftware.desktop' initialised & starting., Sunday, May 13, 2018 08:36:38
[DumaOS] Ubus object 'com.netdumasoftware.networkmonitor' added, attempting to bind pending, Sunday, May 13, 2018 08:36:38
[DumaOS] Ubus object 'com.netdumasoftware.desktop' added, attempting to bind pending, Sunday, May 13, 2018 08:36:38
[DoS Attack: ACK Scan] from source: 5.39.226.189, port 80, Sunday, May 13, 2018 08:36:38
[DumaOS] subscribe to 'com.netdumasoftware.neighwatch' from 'com.netdumasoftware.devicemanager', Sunday, May 13, 2018 08:36:38
[DumaOS] pending subscription for package 'com.netdumasoftware.dpiclass', Sunday, May 13, 2018 08:36:38
[DumaOS] Waiting for 'com.netdumasoftware.autoadmin' to run before starting, Sunday, May 13, 2018 08:36:38
[DumaOS] App 'com.netdumasoftware.devicemanager' initialised & starting., Sunday, May 13, 2018 08:36:38
[DumaOS] pending subscription for package 'com.netdumasoftware.devicemanager', Sunday, May 13, 2018 08:36:38
[DumaOS] pending subscription for package 'com.netdumasoftware.dpiclass', Sunday, May 13, 2018 08:36:38
[DumaOS] Waiting for 'com.netdumasoftware.devicemanager' to run before starting, Sunday, May 13, 2018 08:36:38
[DumaOS] Waiting for 'com.netdumasoftware.autoadmin' to run before starting, Sunday, May 13, 2018 08:36:38
[DumaOS] App 'com.netdumasoftware.geofilter' initialised & starting., Sunday, May 13, 2018 08:36:38
[DumaOS] Resync R-App store cloud, Sunday, May 13, 2018 08:36:39
[uPnP set event: add_nat_rule] from source 192.168.1.2, Sunday, May 13, 2018 08:36:39
[DumaOS] HTTP download failed with code '404', Sunday, May 13, 2018 08:36:39
[DumaOS] R-App store cloud sync failed, Sunday, May 13, 2018 08:36:39
[DumaOS] Ubus object 'com.netdumasoftware.rappstore' added, attempting to bind pending, Sunday, May 13, 2018 08:36:39
[DumaOS] Ubus object 'com.netdumasoftware.rappstore' added, attempting to bind pending, Sunday, May 13, 2018 08:36:39
[DumaOS] Ubus object 'com.netdumasoftware.rappstore' added, attempting to bind pending, Sunday, May 13, 2018 08:36:39
[DumaOS] Ubus object 'com.netdumasoftware.rappstore' added, attempting to bind pending, Sunday, May 13, 2018 08:36:39
[DumaOS] Ubus object 'com.netdumasoftware.rappstore' added, attempting to bind pending, Sunday, May 13, 2018 08:36:39
[DumaOS] Ubus object 'com.netdumasoftware.rappstore' added, attempting to bind pending, Sunday, May 13, 2018 08:36:39
[DumaOS] Ubus object 'com.netdumasoftware.rappstore' added, attempting to bind pending, Sunday, May 13, 2018 08:36:39
[DumaOS] Ubus object 'com.netdumasoftware.rappstore' added, attempting to bind pending, Sunday, May 13, 2018 08:36:39
[DumaOS] Ubus object 'com.netdumasoftware.rappstore' added, attempting to bind pending, Sunday, May 13, 2018 08:36:39
[DumaOS] App 'com.netdumasoftware.rappstore' initialised & starting., Sunday, May 13, 2018 08:36:39
[DumaOS] Ubus object 'com.netdumasoftware.desktop' added, attempting to bind pending, Sunday, May 13, 2018 08:36:39
[DumaOS] Ubus object 'com.netdumasoftware.rappstore' added, attempting to bind pending, Sunday, May 13, 2018 08:36:39
[DumaOS] Ubus object 'com.netdumasoftware.autoadmin' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.autoadmin' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.autoadmin' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.autoadmin' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.autoadmin' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.autoadmin' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Dependency loaded 'com.netdumasoftware.autoadmin', Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.autoadmin' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] All dependencies loaded, starting, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.autoadmin' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Dependency loaded 'com.netdumasoftware.autoadmin', Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.nghal' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.nghal' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.nghal' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.nghal' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.nghal' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.nghal' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.nghal' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.nghal' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.nghal' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[DumaOS] Ubus object 'com.netdumasoftware.nghal' added, attempting to bind pending, Sunday, May 13, 2018 08:36:40
[admin login] from source 192.168.1.2, Sunday, May 13, 2018 08:36:41
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' added, attempting to bind pending, Sunday, May 13, 2018 08:36:42
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' added, attempting to bind pending, Sunday, May 13, 2018 08:36:42
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' added, attempting to bind pending, Sunday, May 13, 2018 08:36:42
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' added, attempting to bind pending, Sunday, May 13, 2018 08:36:42
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' added, attempting to bind pending, Sunday, May 13, 2018 08:36:42
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' added, attempting to bind pending, Sunday, May 13, 2018 08:36:42
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' added, attempting to bind pending, Sunday, May 13, 2018 08:36:42
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' added, attempting to bind pending, Sunday, May 13, 2018 08:36:42
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' added, attempting to bind pending, Sunday, May 13, 2018 08:36:42
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' added, attempting to bind pending, Sunday, May 13, 2018 08:36:42
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' now bound, Sunday, May 13, 2018 08:36:42
[DHCP IP: 192.168.1.6] to MAC address 68:54:fd:b6:ea:65, Sunday, May 13, 2018 08:36:43
[DumaOS] DHCP new event., Sunday, May 13, 2018 08:36:43
[DumaOS] DHCP new lease allocated., Sunday, May 13, 2018 08:36:43
[DumaOS] Cloudsync DPI result 'false','All mirrors are down', Sunday, May 13, 2018 08:36:43
[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' added, attempting to bind pending, Sunday, May 13, 2018 08:36:45
[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' added, attempting to bind pending, Sunday, May 13, 2018 08:36:45
[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' added, attempting to bind pending, Sunday, May 13, 2018 08:36:45
[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' added, attempting to bind pending, Sunday, May 13, 2018 08:36:45
[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' added, attempting to bind pending, Sunday, May 13, 2018 08:36:45
[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' added, attempting to bind pending, Sunday, May 13, 2018 08:36:45
[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' added, attempting to bind pending, Sunday, May 13, 2018 08:36:45
[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' added, attempting to bind pending, Sunday, May 13, 2018 08:36:45
[DumaOS] Dependency loaded 'com.netdumasoftware.devicemanager', Sunday, May 13, 2018 08:36:45
[DumaOS] All dependencies loaded, starting, Sunday, May 13, 2018 08:36:45
[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' added, attempting to bind pending, Sunday, May 13, 2018 08:36:45
[DumaOS] Ubus object 'com.netdumasoftware.nghal' added, attempting to bind pending, Sunday, May 13, 2018 08:36:45
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' added, attempting to bind pending, Sunday, May 13, 2018 08:36:45
[DumaOS] Ubus object 'com.netdumasoftware.dpiclass' now bound, Sunday, May 13, 2018 08:36:45
[DumaOS] Geo-Filter cloudsync result 'true','Geo-Filter is up to date', Sunday, May 13, 2018 08:36:45
[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' added, attempting to bind pending, Sunday, May 13, 2018 08:36:46
[DumaOS] applying qos for zone wan, Sunday, May 13, 2018 08:36:48
[DumaOS] NSS delete root for interface 'brwan', Sunday, May 13, 2018 08:36:48
[DumaOS] applying qos for zone lan, Sunday, May 13, 2018 08:36:49
[DumaOS] NSS delete root for interface 'br0', Sunday, May 13, 2018 08:36:49
[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Sunday, May 13, 2018 08:36:49
[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Sunday, May 13, 2018 08:36:49
[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Sunday, May 13, 2018 08:36:49
[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Sunday, May 13, 2018 08:36:49
[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Sunday, May 13, 2018 08:36:49
[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Sunday, May 13, 2018 08:36:49
[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Sunday, May 13, 2018 08:36:49
[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Sunday, May 13, 2018 08:36:49
[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' now bound, Sunday, May 13, 2018 08:36:49
[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Sunday, May 13, 2018 08:36:49
[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Sunday, May 13, 2018 08:36:49
[DumaOS] applying qos for zone wan, Sunday, May 13, 2018 08:36:55
[DumaOS] applying qos for zone lan, Sunday, May 13, 2018 08:36:56
[DHCP IP: 192.168.1.4] to MAC address 8c:dc:d4:c3:5d:3a, Sunday, May 13, 2018 08:37:03
[DumaOS] DHCP new event., Sunday, May 13, 2018 08:37:03
[DumaOS] DHCP new lease allocated., Sunday, May 13, 2018 08:37:03
[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Sunday, May 13, 2018 08:37:07
[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Sunday, May 13, 2018 08:37:07
[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Sunday, May 13, 2018 08:37:07
[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Sunday, May 13, 2018 08:37:07
[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Sunday, May 13, 2018 08:37:07
[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Sunday, May 13, 2018 08:37:07
[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Sunday, May 13, 2018 08:37:07
[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Sunday, May 13, 2018 08:37:07
[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Sunday, May 13, 2018 08:37:07
[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Sunday, May 13, 2018 08:37:07
[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' now bound, Sunday, May 13, 2018 08:37:07
[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Sunday, May 13, 2018 08:37:07
[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Sunday, May 13, 2018 08:37:07
[DHCP IP: 192.168.1.7] to MAC address 2c:1f:23:98:ae:61, Sunday, May 13, 2018 08:37:51
[DumaOS] DHCP new event., Sunday, May 13, 2018 08:37:51
[DumaOS] DHCP new lease allocated., Sunday, May 13, 2018 08:37:51

Share this post


Link to post
Share on other sites

System Up Time 05:11:37:30

- it is very strange that i cannot re-pro, Ethernet disconnect anymore.

 

random observations:

- after capturing debug logs i noticed that XR500 keeps WAN and LAN captures on USB ( that is new  behavior, factory firmware did not have it, maybe it was a fix?)

- after debugging, memory leak starts, behavior consistent with factory firmware as well, maybe debugging process does not stop, some of the components.

Share this post


Link to post
Share on other sites

Big_dog, when you have this issue, can you login to XR500?

-in case if you can what connection you use wired or wireless?

- what would be connection status? could be found in Setting->Monitoring-connection status? (you can do screenshot before disconnect and compare what you see after)

If router keeps connection then could you ping the IP address, that IP address will not start from 192. or 10., it would be public IP(example of my IP Address 73.225.x.x)?

 

example of my connection status:

Connection Status: it suppose to be a table, but i think it iwll come out as string

IP Address 73.225.x.x Subnet Mask 255.255.254.0 Default Gateway 73.225.x.x DHCP Server 69.252.216.69 DNS Server 75.75.75.75
75.75.76.76 Lease Obtained 4 Days, 0 Hours, 0 Minutes Lease Expires 3 Days, 8 Hours, 1 Minutes

Share this post


Link to post
Share on other sites

Big_dog,  what modem you use, another post made me think is that pattern you see might be not as different from discussed in this thread. do you have a switch laying around anywhere in the house? if so just connect it between modem and XR500, and see if issue comes up again.

 

Also when you install debuging firmware there is a chance that it will improve resistance of XR500.

Share this post


Link to post
Share on other sites

So today, I increased speed with provider to 1gbps down and 40up, router is still running without reboot. Router runs debugging firmware. Will see how this router will perform under high load.

 

I am noticing that traffic management is very officiant with this router, and maybe COD really likes saturation of uplink.

Share this post


Link to post
Share on other sites

Tested 1Gbps for 2 days, router is still stable, with 1gbps speed I still have a limit at 1Tbite a month, I used 10% of that in two days, while testing :) 

But I have positive results on the setup and choice of equipment. Just to remind you guys I downgraded to 150 in the past just to troubleshoot loss of internet, arris sb8200 was not stable.

 

Tested xr500 via 5Ghz wifi.

- at close proximity, 1 wall/floor away from XR500 I get speed tests results as 540-600Mps; where R6700 gets 300Mps max, I think that is ok I do not expect anything more, and I am ok with lowest denominator. 

- with 2 WIFI devices I use the same SID on 5Ghz, in all corners of the house speed is at least 290Mps; wifi coverage: house with garages approximately 4800Sft  

- did concurrent tests as well could not kill "debugging" firmware.

 

I will wait for 15 day mark, and would think that debugging firmware fixed my issue with LAN ports frequent disconnect. the WAN port I am not concerned about since NG CM1000 has stable connection to the router, way better compare to Arris SB8200. 

Share this post


Link to post
Share on other sites

Xbox engineer got back to me and said he spoke with the Netgear team but as we also heard, they couldn't replicate the issue. 

 

He asked me the following, I figured if some people here could chime in then maybe we could isolate the issue a bit more. I think we can all agree it's down to the Instant-On function on Xbox One but maybe it is tied to a specific check or update.

 

"Do you happen to notice any pattern of when the issue hits, e.g. when you mentioned that it may be happening when the console checks for updates, was it when the console was checking for system updates (is your console in Preview and taking frequent updates), or game updates, or when the console has game downloads in queue before going into standby, etc."

Share this post


Link to post
Share on other sites

Sent you a PM.

Hi Fraser.

 

Just to update you. I noticed several days ago that "instant on" was enabled on my xb1x (i thought it was disabled), I disabled it and rebooted router and I have not had a connection drop for a few days now where as it was happening almost daily. I will do wireshark and debug firmware if it appensa again but it is already well past the timeline for disconnecting itself and dropping connections.

Share this post


Link to post
Share on other sites

Hi Fraser.

 

Just to update you. I noticed several days ago that "instant on" was enabled on my xb1x (i thought it was disabled), I disabled it and rebooted router and I have not had a connection drop for a few days now where as it was happening almost daily. I will do wireshark and debug firmware if it appensa again but it is already well past the timeline for disconnecting itself and dropping connections.

 

Great thanks very much for the update.

Share this post


Link to post
Share on other sites

Xbox engineer got back to me and said he spoke with the Netgear team but as we also heard, they couldn't replicate the issue. 

 

He asked me the following, I figured if some people here could chime in then maybe we could isolate the issue a bit more. I think we can all agree it's down to the Instant-On function on Xbox One but maybe it is tied to a specific check or update.

 

"Do you happen to notice any pattern of when the issue hits, e.g. when you mentioned that it may be happening when the console checks for updates, was it when the console was checking for system updates (is your console in Preview and taking frequent updates), or game updates, or when the console has game downloads in queue before going into standby, etc."

 

The issue here is well isolated already netgear just does not want to repro it, or they try to repro with debugging firmware, which by default is stable and has networking stack altered for capture :). So if I would try to repro it now I would say no repro... but if that is true what stops netgear from incorporating additional, software into factory firmware?

 

Issue happens when Xbox is in instant-on mode (in hibernation), there will be frequent port reset on the switch triggered by xbox. Frequency is 1-2min.

the pattern will look like this: 10/full(~1min) -> disconnect/reset(1-5sec)->1000/full(1-5second)->10/full(~1min)->disconnect.

What instant-on-disable going to do? it removes the pattern specified above, so weakness of XR500 is not exposed anymore. If you see disconnect after instant-on-disabled that means issue is different.

 

if I was a netgear engineer in the lab I would connect 4 Xboxes into 2 XR500, put Xboxes  in hibernation and capture repro all day long. Or create generator of pattern and connect generators into XR500, increase frequency and make it 15 seconds per cycle, that could be done by xbox team or netgear team. 

 

Did you talk to tier 1-2 support or to premier support for xbox? Tier 1-2 would be vendors at Microsoft, they will not have incentive to bring that issue to the product team, and would be limited by SOP in troubleshooting.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×