Jump to content

Welcome to Netduma Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Getting Uncaught error messages? Here's the solution!


  • Please log in to reply
18 replies to this topic

#1
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,507 posts
  • Local time: 12:37 PM

If you're getting error messages like these:

Uncaught ReferenceError: Chart is not defined
Uncaught TypeError: c.draggable is not a function  
Uncaught ReferenceError: d3 is not defined
Uncaught TypeError: tree.invalidateData is not a function
Uncaught ReferenceError: topojson is not defined
Uncaught TypeError: Cannot read property 'addWidget' of undefined

Then it is highly likely you have the Bitdefender Anti-Virus/Firewall or another Anti-Virus/Firewall. This guide is specific to Bitdefender at the moment. You need to whitelist the router interface in order to prevent these errors from occurring. Please follow the instructions below:

 

This will allow you to continue to use Bitdefender and access the router interface. If you have a different firewall please let us know so we can contact their support (and it would be great if you can contact their support too). 

 

Do the following steps for http://routerlogin.net and http://192.168.1.1

 

To add a website to the Whitelist:

  1. Click the B icon on the left sidebar of the Bitdefender interface.
  2. Click the VIEW FEATURES link.
  3. In the WEB PROTECTION pane, click Whitelist.
  4. Provide the address of the blocked website or online application in the corresponding field and click Add.
  5. Click Save to save the changes and close the window.

Only websites and applications that you fully trust should be added to this list.These will be excluded from scanning by the following engines: malware, phishing and fraud.

 

Once you have done the above you will need to reboot your PC, then access the interface and do a refresh without caching, please see this guide for your particular browser on how to do that: https://en.wikipedia...Bypassing_cache

 

If after putting through the exceptions you're still encountering the issue disable Bitdefender fully by following this guide: https://www.bitdefen...rt/answer/3347/

 

The Bitdefender update is out so you should not longer get this issue with Bitdefender enabled.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST

World Clock

Official DumaOS/XR500 Support Times: 12pm - 2am BST



If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#2
iAmMoDBoX

iAmMoDBoX

    argument-jedi-mindshitter

  • Moderators
  • 2,994 posts
  • Local time: 07:37 AM

This happened on my iPhone


Posted Image


Posted Image


#3
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,507 posts
  • Local time: 12:37 PM

This happened on my iPhone

 

That is probably just due to the fact that we are not supporting the interface being used on a mobile at the moment.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST

World Clock

Official DumaOS/XR500 Support Times: 12pm - 2am BST



If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#4
iAmMoDBoX

iAmMoDBoX

    argument-jedi-mindshitter

  • Moderators
  • 2,994 posts
  • Local time: 07:37 AM

That is probably just due to the fact that we are not supporting the interface being used on a mobile at the moment.

 

That's what I figured


Posted Image


Posted Image


#5
peanut183

peanut183

    Member

  • Early Access
  • PipPip
  • 15 posts
  • Local time: 04:37 AM

Didn't work for me. I also tried the Stealth Mode settings in a different thread. I whitelisted, cleared cache, tried with Chrome, Edge, and IE. All give differing errors. I'm not able to use the GeoFilter section at all and the Dashboard gives errors on Edge. Right now I'm barely able to configure the router.



#6
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,507 posts
  • Local time: 12:37 PM

We reproduced the issue today and gave the necessary information to the Bitdefender team so should have a proper fix soon. Please try disabling it fully by following this, do you still get the same issue? https://www.bitdefen...rt/answer/3347/

 

I found it very hard on their software as there as so many different options that it's likely it still needs to be whitelisted elsewhere on the software, I'll be able to check this tomorrow.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST

World Clock

Official DumaOS/XR500 Support Times: 12pm - 2am BST



If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#7
peanut183

peanut183

    Member

  • Early Access
  • PipPip
  • 15 posts
  • Local time: 04:37 AM

We reproduced the issue today and gave the necessary information to the Bitdefender team so should have a proper fix soon. Please try disabling it fully by following this, do you still get the same issue? https://www.bitdefen...rt/answer/3347/

 

I found it very hard on their software as there as so many different options that it's likely it still needs to be whitelisted elsewhere on the software, I'll be able to check this tomorrow.

 

Cool. Thanks for all your help.



#8
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,507 posts
  • Local time: 12:37 PM

Good news: Had a Bitdefender developer take a look at my PC while the issue was occurring with Bitdefender enabled. They said at the time that they think they know what is causing the issue & how to fix it so with any luck we'll see a fix soon, either in the form of a patch on their software or a hotfix for the router.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST

World Clock

Official DumaOS/XR500 Support Times: 12pm - 2am BST



If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#9
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,507 posts
  • Local time: 12:37 PM

Just heard back from Bitdefender, they will do the fix on their end. I will post back when their update is out.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST

World Clock

Official DumaOS/XR500 Support Times: 12pm - 2am BST



If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#10
Badger3k

Badger3k

    Member

  • Early Access
  • PipPip
  • 12 posts
  • Local time: 05:37 AM

Any news yet?  The situation has gotten worse.  I did the whitelist but that didn't work.  Running the Bitdefender total security on my laptop but the router is connected through the Box2.  Should I contact Bitdefender directly too?



#11
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,507 posts
  • Local time: 12:37 PM

Any news yet?  The situation has gotten worse.  I did the whitelist but that didn't work.  Running the Bitdefender total security on my laptop but the router is connected through the Box2.  Should I contact Bitdefender directly too?

 

I let them know later last week so not sure how much time they would have spent so far on a fix. There is no need for you to contact them as they are already aware and working on the fix, I provided them with all the debug information they needed. I will chase them for an update.

 

I'd suggest disabling it for now if it's really becoming an issue: https://www.bitdefen...rt/answer/3347/


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST

World Clock

Official DumaOS/XR500 Support Times: 12pm - 2am BST



If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#12
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,507 posts
  • Local time: 12:37 PM

Any news yet?  The situation has gotten worse.  I did the whitelist but that didn't work.  Running the Bitdefender total security on my laptop but the router is connected through the Box2.  Should I contact Bitdefender directly too?

I let them know later last week so not sure how much time they would have spent so far on a fix. There is no need for you to contact them as they are already aware and working on the fix, I provided them with all the debug information they needed. I will chase them for an update.

 

I'd suggest disabling it for now if it's really becoming an issue: https://www.bitdefen...rt/answer/3347/

 

As a follow up Bitdefender has said the fix should be out this week. 


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST

World Clock

Official DumaOS/XR500 Support Times: 12pm - 2am BST



If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#13
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,507 posts
  • Local time: 12:37 PM

We're just testing Bitdefenders fix, assuming it works they'll put out an update.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST

World Clock

Official DumaOS/XR500 Support Times: 12pm - 2am BST



If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#14
peanut183

peanut183

    Member

  • Early Access
  • PipPip
  • 15 posts
  • Local time: 04:37 AM

We're just testing Bitdefenders fix, assuming it works they'll put out an update.

 

Any idea if this was ever released by BD? I'm still seeing.

 

"Uncaught TypeError: tree.invalidateData is not a function" - Device Manager

"Uncaught ReferenceError: d3 is not defined" - QoS

"Uncaught ReferenceError: d3 is not defined" - Geofilter

 

I can't use any of the above features as their UI doesn't load.



#15
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,507 posts
  • Local time: 12:37 PM

Any idea if this was ever released by BD? I'm still seeing.

 

"Uncaught TypeError: tree.invalidateData is not a function" - Device Manager

"Uncaught ReferenceError: d3 is not defined" - QoS

"Uncaught ReferenceError: d3 is not defined" - Geofilter

 

I can't use any of the above features as their UI doesn't load.

 

Hi Peanut, I just had some correspondence with them today. On Friday I tested the fix and it didn't seem to work, however upon testing it today I can confirm it did work and stopped the errors on the interface. As such I suspect they will push out an update imminently. I will let you know as soon as I have confirmation that they've done so.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST

World Clock

Official DumaOS/XR500 Support Times: 12pm - 2am BST



If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#16
peanut183

peanut183

    Member

  • Early Access
  • PipPip
  • 15 posts
  • Local time: 04:37 AM

Hi Peanut, I just had some correspondence with them today. On Friday I tested the fix and it didn't seem to work, however upon testing it today I can confirm it did work and stopped the errors on the interface. As such I suspect they will push out an update imminently. I will let you know as soon as I have confirmation that they've done so.

 

Thank you so much for the update and the quick response on this issue.



#17
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,507 posts
  • Local time: 12:37 PM

Just had an ETA from Bitdefender, it will be about 2 weeks until the update is available from them.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST

World Clock

Official DumaOS/XR500 Support Times: 12pm - 2am BST



If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#18
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,507 posts
  • Local time: 12:37 PM

Just so everyone is aware, the Bitdefender update is out so you should not longer get this issue with Bitdefender enabled.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST

World Clock

Official DumaOS/XR500 Support Times: 12pm - 2am BST



If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#19
simjc

simjc

    Member

  • Clubhouse Member
  • PipPipPip
  • 204 posts
  • Local time: 12:37 PM

Just so everyone is aware, the Bitdefender update is out so you should not longer get this issue with Bitdefender enabled.

 

Woo hooo!!! :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users