Jump to content

xr450owner

Members
  • Content count

    12
  • Joined

  • Last visited

  1. xr450owner

    XR450 Wi-Fi Calling Being Blocked

    Finally got around to testing suggested settings. I updated to the latest firmware (2.3.2.40) and tested @Killhippie settings. Still not working. My return window closes this week so I’ll be forced to return the router. Was hoping to keep for the geo filter feature but no WiFi calling is a killer.
  2. xr450owner

    XR450 Wi-Fi Calling Being Blocked

    Testing performed with TP-Link Archer C8 router: So now I am 100% convinced it's an issue with the Netgear router. Plugged in my old router and connected both iPhone 7 and 7 Plus. Put both in airplane mode. Both phones immediately popped up with the Wi-Fi icon and I was able to make calls, no blockage at all. Both had the clear sound quality associated with Wi-Fi calling. I love the XR450 for everything but it's inability to support Wi-Fi calling on iPhones. I will be forced to go back to my TP-Link for now. Can any admins confirm this issue will be fixed anytime soon with Netgear?
  3. xr450owner

    XR450 Wi-Fi Calling Being Blocked

    Recent troubleshooting efforts with XR450: UPnP turned on, Disable SIP ALG checked, Disable IGMP checked, no port forwarding or triggering enabled, no QoS enabled. iPhone 7, iOS 11.4.1, Verizon: Wi-Fi calling not working. Turning off cellular data still allows me to make calls. Turning Airplane mode on, with only Wi-Fi enabled, does not allow Wi-Fi calling, icon does not even pop up even though Wi-Fi calling option is enabled on device. Seems to be blocked. iPhone 7 Plus, iOS 12.1.1, AT&T: Had Wi-Fi calling reset around noon by carrier. Turning off cellular data still allows me to make calls. Wi-Fi calling intermittent, but can't confirm it's actually Wi-Fi calling and not cellular. Turning on airplane mode with only Wi-Fi enabled, Wi-Fi icon popped up once and I made a call, but sound quality sounds like cellular. Initially worked with Airplane mode on, but now will not. Seems to be blocked. Samsung S6, 7.0, Verizon: Wi-Fi calling appears to be working. Put device in airplane mode. Turned only Wi-Fi on and was able to make calls. Cellular option isn't even available when airplane mode is turned on, as should be the case.
  4. xr450owner

    XR450 Wi-Fi Calling Being Blocked

    This appears to the most concise article on what is required from a network level to allow WiFi calling that I have found. Will report back after I do more testing at home https://www.networkcomputing.com/networking/your-network-optimized-wifi-calling/292001714
  5. xr450owner

    XR450 Wi-Fi Calling Being Blocked

    I totally agree, airplane mode should shut everything off, except if you turn on WiFi and Bluetooth manually. But on iOS, i am not convinced it does. I have no way of ensuring the device is using Wi-Fi calling, except for that logo. But I dont think that logo means it is for sure using wifi calling. For when I was able to make a call on airplane mode, i believe it was cellular because the voice quality sounded muddy like on 4G and not crystal clear like when on Wi-FI calling. All the other times my phone attempts to call on Wi-Fi, its straight up call failed, like its being blocked. Also, I have a Galaxy S6 and it appears to be working just fine with Wi-Fi calling on the XR450. More variables to add to the madness.
  6. xr450owner

    XR450 Wi-Fi Calling Being Blocked

    I ensured cellular data is turned off which got me thinking. That toggle is worded cellular “data” and not necessarily cellular “voice” as well. I can confirm data does not work with it turned off along with WiFi. But does that toggle truly disable all carrier functionaity on the device? The rabbit hole grows deeper. Lol.
  7. xr450owner

    XR450 Wi-Fi Calling Being Blocked

    @xr500user I have been playing around with turning on airplane mode to test WiFi calling. Call me crazy, but it appears airplane mode doesnt actually disable all cellular calling ability. I was able to make a call with airplane mode on, and not using WiFi calling. On my iPhone 7 when WiFi calling is fully enabled, it says “call failed.” And I’ve noticed that even though the “WiFi calling” logo is presented on the device, it doesn’t actually mean its 100% using that feature. I think the mobile OS decides which to use based on signal strength.
  8. xr450owner

    XR450 Wi-Fi Calling Being Blocked

    @Killhippie I will reach out to my carrier to see if that fixes it. Thanks @major masingil interesting. This stream seems to point back at Router OS. Someone from DumaOS even mentioned fixing this issue is on their roadmap. It’s crazy how all over the place this issue is. To me, nothing I’ve read from all the threads I’ve seen confirms anyone really knows what’s going on, other than it doesn’t work. Haha. Crazy stuff. Praying for a magic software fix, somewhere.
  9. xr450owner

    XR450 Wi-Fi Calling Being Blocked

    I have a stand-alone SurfBoard modem without routing capabilities. I have an Archer C8 router that had worked with Wi-Fi calling in the past. I will try setting that up again to see if it still works. It sounds like there are many variables that go into WiFi calling that could be points of failure. Things like device, device OS, router and carrier all play parts. Makes it very hard to lock down a solid process.
  10. xr450owner

    XR450 Wi-Fi Calling Being Blocked

    I just tried adding the IP address of an iPhone that is not working with Wi-Fi calling to the DMZ. That did not fix the issue. Weird thing is, now when I re-add that same device IP to port forwarding feature, it's not working either! I was hoping to have narrowed this issue down, but it appears to be just as intermittent as before. This is driving me nuts haha.
  11. xr450owner

    XR450 Wi-Fi Calling Being Blocked

    Hello and thanks for the quick reply! Unfortunately, toggling the SIP ALG and IGMP Proxying options did not work for me. This was part of my testing as I read about this possibility on other threads. Yes, UPnP is enabled. I played around with increasing the Time to Live, but that didn't work either. So far, the only thing that has allowed Wi-Fi calling is allowing UDP traffic on ports 500 and 4500 with either Port Forwarding or Port Triggering. Other than that, Wi-Fi calling fails. Might there be a fundamental issue with the built in UPnP feature, if that should be allowing Wi-Fi calling traffic? Is there a known bug or intention to release a new firmware version to improve?
  12. Ever since purchasing my XR450 router, Wi-Fi calling on my iPhone 7 (AT&T) and iPhone X (Verizon) stopped working. After hours of research online, it appears as though the router is blocking required traffic on ports 500 and 4500 (I think it's called IPSEC traffic). According to Apple's support site, both these ports for UDP traffic need to be allowed. Ideally, I want all devices that connect to my router to be allowed Wi-Fi calling. I was able to get it working on a single device by configuring port forwarding, but unfortunately this method only allows this traffic for one device. I then started playing around with port triggering to allow the traffic on multiple devices. I got it to work briefly by creating (2) rules and setting Service Type:500 and Service Type:4500. I am unsure what to put for the inbound port range, so I just put a large range. Unfortunately, it stopped working after around 10 minutes. With this, I have a few questions: What is the ideal way to configure this router to enable Wi-Fi calling on all connected devices? For the port triggering method mentioned above, is there a recommended range for the inbound port section of each rule? Thanks!
×